AboutDownloadsDocumentsForumsSource CodeIssuesNews
2014-09-17 04:30
Submitted by:
Alessandro Timmi (alex_karate_do)
Assigned to:
Ayman Habib (aymanh)
"Fixed" checkbox for a marker doesn't work

Detailed description
Dear OpenSim team,
I'm playing around with a new markerset. In this markerset I need some markers to be "fixed", so I set the corresponding node on "true" and saved the markerset file (I tried doing this both from the GUI and from notepad, but the bug i'm pointing out is always present).

Loading my markerset again (for example when I start OpenSim and open my skeleton model) I noticed that the tick in the checkbox corresponding to the "fixed" property is missing for those markers.

I tried several times, I also checked my markerset file in notepad++ and the <fixed> node is correctly set on "true" for those markers I want to be fixed. Simply, OpenSim GUI seems not to detect the state of this node correctly.

Anyway, I tried scaling with this markerset and the markers are properly considered as fixed by the scale tool. Indeed, when I checked the same markers in the scaled model, their positions are exactly the same as in the original (not scaled) model.

Therefore, this seems to be a sort of "cosmetic" bug, not a functional one, but quite annoying because it is difficult for the user to detect which markers are fixed in the current markerset. The only way is to open the markerset file in a text editor.

Thanks for your kind attention.

Yours faithfully,

Alessandro Timmi

Add A Comment: Notepad

No Comments Have Been Posted

No Changes Have Been Made to This Item