Share 
Follow 
AboutDownloadsDocumentsForumsSource CodeIssuesNews
Date:
2009-06-18 21:05
Priority:
3
State:
Open
Submitted by:
Samuel Flores (sam)
Assigned to:
Samuel Flores (sam)
Summary:
problem with initialization of currentStage, caught at globalCoulombScaleFactor check

Detailed description


Sam,
I tried sending an email to rnatoolbox-help@simtk.org but the email
bounced. Below is the error message.

Kishor.
------------------------

This is the Postfix program at host mail.simtk.org.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<rnatoolbox-help@simtk.org>: Command died with status 1:
"/var/www/html/simtk/cronjobs/forum_gateway.php rnatoolbox help". Command
output: local: fatal: execvp
/var/www/html/simtk/cronjobs/forum_gateway.php: No such file or directory

Final-Recipient: rfc822; rnatoolbox-help@simtk.org
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; Command died with status 1:
"/var/www/html/simtk/cronjobs/forum_gateway.php rnatoolbox help". Command
output: local: fatal: execvp
/var/www/html/simtk/cronjobs/forum_gateway.php: No such file or directory

2009/6/17 Samuel Coulbourn Flores <scflores@stanford.edu>:
Well we have a bug report/feature request page. You can submit a feature
request by going to the RNAToolbox project page and clicking advanced ->
click Features & bugs -> select either features or bug -> click add new.


https://simtk.org/tracker/?group_id=359
As for your programming question, I can tell you how to add the feature you
want to your custom build, though it would be great if you could post it to
the help list.
Thanks
Sam

On Jun 16, 2009, at 9:14 AM, Kishor Bhalerao wrote:

Sam,
Do you want me to post the feature requests for RNABuilder on the
rnatoolbox forums ?

Kishor.

2009/6/15 Samuel Coulbourn Flores <scflores@stanford.edu>:

Hi Kishor,

Could you sign up for the rnatoolbox-help list, and ask this question there?

I will post my answer on there.

https://simtk.org/mailman/listinfo/rnatoolbox-help

Sam


On Jun 14, 2009, at 8:03 AM, Kishor Bhalerao wrote:

Hi Sam,

I have got it to work for the moment in a roundabout manner. Here is

the procedure i followed.

This time i downloaded the source from branches/v1_0 and rebuilt in

debug mode. (All my previous efforts were with the code obtained from

trunk)

In the ParameterReader.h, i changed the variable weldToGround from a

bool to an int to match with the ParameterReader.h from trunk/include

and also the corresponding line weldToGround = aToBool(mystring[0],

mystring[1].c_str() ); to atoi(mystring[1].c_str())

This change was more than sufficient to get it to work with all

commands other than SingleBondMobilityTorsion/Rigid/Free.

To include this command, i simply copied the corresponding lines from

the parameterReader.h and repel.h from trunk/include to the source in

branches/v1_0/include and copied the file setSingleBondMoblity.h from

trunk/include

I had another request. It seems to me that the RNABuilder.exe (Binary

for windows) which is currently available in the downloads section of

the RNABuilder website is not built from trunk but is built from

branches/v1_0 since it requires weldToGround as a bool and does not

support the command SingleBondMobilityTorsion/Rigid/Free. It would be

great if you can build this binary/executable which will support the

command SingleBondMobilityTorsion/Rigid/Free for windows and make it

available on RNABuilder website.

Thank you for your time.

Kishor Bhalerao

2009/6/13 Samuel Coulbourn Flores <scflores@stanford.edu>:

Hi Kishor,

We have not been able to reproduce your bug. As a last resort, how about if

you delete all of your RNABuilder source, check it out again, and rebuild?

Crazy, but very often works. You might try doing the same with Simbody,

though I'm much less confident that this will make a difference.

The best thing to do, I think, is to just check out an earlier revision of

RNABuilder. svn makes this easy. I don't think there are any recent

changes that benefit you all that much. I'm afraid Jack won't have time to

do much more than he has already.

Let me know if this works.

Sam

On Jun 12, 2009, at 9:21 AM, Kishor Bhalerao wrote:

Hi Jack,

find attached the file.

Regards,

Kishor.

On Fri, Jun 12, 2009 at 12:07 PM, Jack Middleton<jacklm@stanford.edu> wrote:

Hi Kishor,

I am having a hard time reproducing your bug.

Can you also send me the Base-interaction-paramters.4.csv file you are

using?

Thanks,

Jack


----- Original Message -----

From: "Kishor Bhalerao" <kishor8dm@gmail.com>

To: "Samuel Coulbourn Flores" <scflores@stanford.edu>

Cc: "Jack Middleton" <jacklm@stanford.edu>

Sent: Tuesday, June 9, 2009 5:50:53 PM GMT -08:00 US/Canada Pacific

Subject: Re: RNABuilder Bug ?

Hi Sam,

It still does not work for me. I have the latest version of rnatoolbox

which i was able to build and install without any errors. I got the

source from https://simtk.org/svn/rnatoolbox/trunk using svn. I do not

know what the -c option is. I am using MS Visual Studio Express

edition.

Next, I am certain it is reading my contacts.dat file, after reading

the file, the output is printed on the screen and i can clearly see

the comments i had inserted in the contacts.dat file.

The assert which fails is assert (myParameterReader2.lastStage >=

myParameterReader2.firstStage);

Now, i can very clearly see that the variables lastStage and

firstStage are still at the default value of 0 and 1 respectively and

have not been initialized to the values i set in the contacts.dat

file.

myParameterReader2.initialize("./contacts.dat");

cout<<"[RNABuilder.cpp] lastStage = "<<myParameterReader2.lastStage<<endl;

cout<<"[RNABuilder.cpp] firstStage =

"<<myParameterReader2.firstStage<<endl;

assert (myParameterReader2.lastStage >= myParameterReader2.firstStage);

I cannot get past this assert. Do you have any suggestions ?

Kishor


On Tue, Jun 9, 2009 at 7:45 PM, Samuel Coulbourn

Flores<scflores@stanford.edu> wrote:

Hi Kishor,

I just ran this and it runs fine. Looks like you have a tetraloop in there,

but no receptor. Are you sure you have the contacts.dat file in the

directory from which you are calling RNABuilder? are you using the -c flag?

Did you build from the latest revision in trunk?

Don't try to hack the code. I assure you, the problem is not in the code.

If you want I can try to log in to your machine and troubleshoot. However I

suspect your problem is a trivial one. I'm cc'ing Jack in case he has

something to say.

Sam

On Jun 6, 2009, at 3:52 PM, Kishor Bhalerao wrote:

Hi Sam,

I recently updated RNABuilder source and my contacts.dat file which

was working before fails. I have attached the file with this email.

assert (myParameterReader2.lastStage >=

myParameterReader2.firstStage); This is the assert which throws the

error. I checked the code and found that in the function

void ParameterReader::initializeDefaults() the variable currentStage

is not initialized to any value. Its commented out. This variable gets

used without being initialized on line 478 in the file

ParameterReader.h in the function

ParameterReader::initializeFromFileOnly()

I tried to set this value to 0 in the function initializeDefaults()

and now i get stuck at the assert(foundCoulomb); on line 319 in file

ParameterReader.h in function removeNonPriorityBasePairs().

Do you have any idea what am i doing wrong ?

Regards,

Kishor Bhalerao

PS : I have also tried setting currentStage = 1. ( My guess from the

name of the variables was that currentStage and FirstStage should have

identical default values.) On setting this value, The code fails after

printing

[Repel.h] About to fit RNA chain A.

Assertion failed: a.bodyIx.isValid(), file

..\..\src\DuMMForceFieldSubsystemRep.cpp, line 187

<contacts.dat>

Samuel Coulbourn Flores, PhD

Altman Lab

650.644.8416

花山

科学者

生物工学部

スタンフォ一ド大学

スタンフォ一ド、カリフォルニア、米国




















<Base-interaction-parameters.4.csv>

Samuel Coulbourn Flores, PhD

Altman Lab

650.644.8416

花山

科学者

生物工学部

スタンフォ一ド大学

スタンフォ一ド、カリフォルニア、米国




















Samuel Coulbourn Flores, PhD

Altman Lab

650.644.8416

花山

科学者

生物工学部

スタンフォ一ド大学

スタンフォ一ド、カリフォルニア、米国




















Samuel Coulbourn Flores, PhD
Altman Lab
650.644.8416
花山
科学者
生物工学部
スタンフォ一ド大学
スタンフォ一ド、カリフォルニア、米国


















Add A Comment: Notepad

Message  ↓
Date: 2009-06-18 21:13
Sender: Samuel Flores

Hi Kishor,

I am not sure why I was not getting this error previously. However I can now observe it and have corrected as follows:

The following line is now at line 75, whereas before it was around line 73 where it could be invalidated by any initialization in the subsequent calls to initialize(). New line:

75 myParameterReader.currentStage = i;

Now it is safe to initialize currentStage in ParameterReader.h:

1085 currentStage=0; //scf put this back in following Kishor's comment

RNABuilder now runs on my machine. Please test on yours.

Sam

Field Old Value Date By
assigned_tonone2009-06-18 21:13sam
Feedback