Share 
Follow 
AboutDownloadsDocumentsForumsSource CodeIssuesNews
Date:
2012-02-06 15:21
Priority:
3
State:
Open
Submitted by:
Ward Bartels (warre)
Assigned to:
Ayman Habib (aymanh)
Summary:
OpenSim fails to load a model if the file path contains a special character (ë)

Detailed description
I tried to load an OpenSim model file with an additional Geometry dir. The file path included a directory name containing a special character (ë, or e with a diaeresis, rather specific to the Dutch language).

This produced the following error:
"Could not construct a model from D:\Profiles\Windows\Desktop\ë\PreOp_cust_0.osim.
Object: ERR- Could not open file D:\Profiles\Windows\Desktop\ë\PreOp_cust_0.osim. It may not exist or you don't have permission to read it."

Strangely, it is possible to import a SIMM model. A correct OpenSim model will be produced, but OpenSim will refuse to open it with this message:
"Error opening converted model file D:\Profiles\Windows\Desktop\ë\PreOp_cust_0.osim"

This behaviour seems to be caused by the special character ë being included somewhere on the file path. It can be worked around by moving the model somewhere else.

I know the easiest solution is not to use these characters in directory names. Still, I think the error messages should be made more specific so if people run into the same problem in the future they can quickly find the cause.

Additional information:
OS is Windows 7 pro 64-bit, NTFS-partitioned
OpenSim version 2.4.0

Add A Comment: Notepad

Message  ↓
Date: 2020-11-05 11:02
Sender: Karin Lundengard

Got the same same error on a swedish computer where "user" is called "användare" and can not really be changed without messing up a lot of other stuff...
Weirdly, it worked in earlier versions of OpenSim.

No Changes Have Been Made to This Item

Feedback